Monday, December 1, 2014

Shellshocked.

It's been several months since the public has become aware of the ShellShock bug. So all of you Linux, BSD, UNIX, and Mac users out there, if the following command works in your shell, you're vulnerable to one of the most devistating *nix bugs around (STILL!). Yes, all you new Ubuntu / Mint / Fedora users out there, I'm talking to you. If you have no idea what in the world I'm talking about, then I'm talking to YOU.
env check='Not vulnerable' x='() { :;}; check=Vulnerable' bash -c 'echo $check'
If you see "Not vulnerable", you're good to go. everyone else, please see your distribution's website for updates... like yesterday.
Post a Comment